Support Email Ticketing System

Incident Report for Vega Cloud

Resolved

The issue previously preventing support tickets from being created via email has been resolved by our third-party ticketing provider.
Posted Oct 20, 2025 - 20:40 UTC

Monitoring

We are currently experiencing an issue with our third-party ticketing system that is preventing inbound emails to our support address from being received.

If you need to open a support ticket, please submit your request directly through our Support Portal at:

https://vegacloud.freshservice.com
Posted Oct 20, 2025 - 15:40 UTC
This incident affected: Vega Platform Inform, Vega Platform Optimize, and Vega Platform Operate.